[PATCH v1 1/3] Prepare inet_ntop to be fortified
Florian Weimer
fweimer@redhat.com
Wed Mar 19 14:02:21 GMT 2025
* Frédéric Bérat:
> Rename inet_ntop to __inet_ntop and create the inet_ntop weak alias
> based on it in order to prepare for disabling fortification when
> available.
> ---
> include/arpa/inet.h | 4 +++-
> nss/getnameinfo.c | 4 ++--
> resolv/inet_ntop.c | 7 ++++---
> 3 files changed, 9 insertions(+), 6 deletions(-)
Looks good now.
Reviewed-by: Florian Weimer <fweimer@redhat.com>
Thanks,
Florian
More information about the Libc-alpha
mailing list