[PATCH 1/3] Prepare inet_ntop to be fortified
Florian Weimer
fweimer@redhat.com
Tue Mar 18 11:58:31 GMT 2025
* Frédéric Bérat:
> Rename inet_ntop to __inet_ntop and create the inet_ntop weak alias
> based on it in order to prepare for fortification.
As far as I understand it, this change prepares for disabling internal
fortification of inet_ntop. It probably should say so somewhere. 8-)
> diff --git a/resolv/inet_ntop.c b/resolv/inet_ntop.c
> index c4d38c0f95..f9312cb919 100644
> --- a/resolv/inet_ntop.c
> +++ b/resolv/inet_ntop.c
> -libc_hidden_def (inet_ntop)
> +libc_hidden_def (__inet_ntop)
> +weak_alias (__inet_ntop, inet_ntop)
> +
>
> /* const char *
> * inet_ntop4(src, dst, size)
Extra newline. Rest looks okay. With the newline removed:
Reviewed-by: Florian Weimer <fweimer@redhat.com>
Thanks,
Florian
More information about the Libc-alpha
mailing list