[PATCH v2] manual: Correct return value description of 'clock_nanosleep'

Arjun Shankar arjun@redhat.com
Mon Jun 2 21:43:24 GMT 2025


Hi Maciej,

>  I can see this has been pushed already, however I have pondered it since
> the discovery of the issue and on second thoughts I'd rather we had the
> example here.  I often find matters quicker to digest where one is given.
> Obviously we need to be careful to avoid confusion, but how about
> inserting:
>
> "
> Barring the return value convention and the way to communicate an error
> condition the call:
>
> @smallexample
> nanosleep (@var{requested_time}, @var{remaining_time})
> @end smallexample
>
> is analogous to:
>
> @smallexample
> clock_nanosleep (CLOCK_REALTIME, 0, @var{requested_time}, @var{remaining_time})
> @end smallexample
> "
>
> immediately following the paragraph quoted above?

Seems reasonable to me. Would you like to post a patch to this effect?
Or would you like me to do it? I can later this week once I finish
another manual change I'm trying to get done.



More information about the Libc-alpha mailing list