[PATCH v2 0/3] Improve TEST_CC/TEST_CXX testing with clang

Adhemerval Zanella adhemerval.zanella@linaro.org
Tue Dec 9 14:58:31 GMT 2025


Some testing options are not supported by ld.ldd, so it requires using
TEST_CC instead of CC for some linker options. clang also optimizes away
some newer malloc symbols, so extend the tst-malloc-aux.h for pvalloc
and reallocarray.

Changes from v1:
* Renamed ibc_cv_XXX variables should be renamed to libc_cv_test_XXX.
* Replace -Ttext-segment with --image-base.

Adhemerval Zanella (3):
  configure: use TEST_CC to check for --no-error-execstack
  configure: use TEST_CC to check for --depaudit
  configure: replace -Ttext-segment -with --imgage-base

 aclocal.m4   | 32 ++++++++++++++++++++++++++++++++
 configure    | 47 ++++++++++++++++++++++++++++-------------------
 configure.ac | 28 ++++++++++++++--------------
 3 files changed, 74 insertions(+), 33 deletions(-)

-- 
2.43.0



More information about the Libc-alpha mailing list