[PATCH v2 00/10] Remove fastbins

DJ Delorie dj@redhat.com
Tue Dec 9 02:28:55 GMT 2025


Dev Jain <dev.jain@arm.com> writes:
> v1->v2:
>  - Rename FASTBIN_CONSOLIDATION_THRESHOLD to ATTEMPT_TRIMMING_THRESHOLD
>  - Rename _int_free_maybe_consolidate to _int_free_maybe_trim
>  - Preserve mallinfo(2).smblks/fsmblks for back compat
>  - Start loop from i = 1, preserve <sizes>, in patch 6
>  - Remove mxfast tunable path, preserving only the mxfast mallopt path
>  - Add patch to remove do_check_remalloced_chunk
>  - Remove comments along with code as much as possible

I confirmed these, and compared the v2 patch set to the v1 patch set for
all the patches I'd already approved, and have reviewed the remaining
patches and reviewed those too, so you should be all set here.

The only bit left is that the MXFAST tunable definition is still left in
elf/dl-tunables.list but (1) I see no harm in that, (2) it helps with
ABI compatiblility between ld-linux and libc, and (3) I can't think of a
three.  We can remove it later if it's problematic.



More information about the Libc-alpha mailing list