[PATCH 0/5] Improve TEST_CC/TEST_CXX testing with clang
Adhemerval Zanella Netto
adhemerval.zanella@linaro.org
Mon Dec 8 12:49:24 GMT 2025
On 05/12/25 22:56, H.J. Lu wrote:
> On Sat, Dec 6, 2025 at 3:13 AM Adhemerval Zanella
> <adhemerval.zanella@linaro.org> wrote:
>>
>> Some testing options are not supported by ld.ldd, so it requires using
>> TEST_CC instead of CC for some linker options. clang also optimizes away
>> some newer malloc symbols, so extend the tst-malloc-aux.h for pvalloc
>> and reallocarray.
>
> I think all libc_cv_XXX variables should be renamed to libc_cv_test_XXX
> if they are only used for tests,
Ack, I will do it.
>
>>
>> Adhemerval Zanella (5):
>> configure: use TEST_CC to check for --no-error-execstack
>> configure: use TEST_CC to check for --depaudit
>> configure: use TEST_CC to check for -Ttext-segment
>> malloc: Extend malloc function hiding to tst-pvalloc (BZ #32366)
>> malloc: Extend malloc function hiding to tst-reallocarray (BZ #32366)
>>
>> aclocal.m4 | 32 ++++++++++++++++++++++++++
>> configure | 47 +++++++++++++++++++++++++++++++++++++++
>> configure.ac | 21 +++++++++++------
>> malloc/tst-malloc-aux.h | 3 +++
>> malloc/tst-pvalloc.c | 1 +
>> malloc/tst-reallocarray.c | 1 +
>> 6 files changed, 98 insertions(+), 7 deletions(-)
>>
>> --
>> 2.43.0
>>
>
>
More information about the Libc-alpha
mailing list