[PATCH v2 2/2] misc: Align argument name for pkey_*() functions with the manual
Joe Simmons-Talbott
josimmon@redhat.com
Tue Oct 22 13:34:49 GMT 2024
On Tue, Oct 22, 2024 at 8:43 AM Yury Khrustalev <yury.khrustalev@arm.com>
wrote:
> Change name of the "rights" argument to "restrictions" of the
> following functions:
>
> - pkey_alloc()
> - pkey_set()
>
> as this argument refers to access restrictions rather than access
> rights and previous name might have been misleading.
> ---
> sysdeps/unix/sysv/linux/bits/mman-shared.h | 12 ++++++------
> sysdeps/unix/sysv/linux/pkey_set.c | 2 +-
> 2 files changed, 7 insertions(+), 7 deletions(-)
>
> diff --git a/sysdeps/unix/sysv/linux/bits/mman-shared.h
> b/sysdeps/unix/sysv/linux/bits/mman-shared.h
> index d8ed4436b6..629b0dcf20 100644
> --- a/sysdeps/unix/sysv/linux/bits/mman-shared.h
> +++ b/sysdeps/unix/sysv/linux/bits/mman-shared.h
> @@ -42,7 +42,7 @@
> # define MLOCK_ONFAULT 1U
> # endif
>
> -/* Access rights for pkey_alloc. */
> +/* Access restrictions for pkey_alloc. */
> # ifndef PKEY_DISABLE_ACCESS
> # define PKEY_DISABLE_ACCESS 0x1
> # define PKEY_DISABLE_WRITE 0x2
> @@ -59,16 +59,16 @@ int memfd_create (const char *__name, unsigned int
> __flags) __THROW;
> int mlock2 (const void *__addr, size_t __length, unsigned int __flags)
> __THROW;
>
> /* Allocate a new protection key, with the PKEY_DISABLE_* bits
> - specified in ACCESS_RIGHTS. The protection key mask for the
> + specified in RESTRICTIONS. The protection key mask for the
>
I think we should use ACCESS_RESTRICTIONS here.
> current thread is updated to match the access privilege for the new
> key. */
> -int pkey_alloc (unsigned int __flags, unsigned int __access_rights)
> __THROW;
> +int pkey_alloc (unsigned int __flags, unsigned int __restrictions)
> __THROW;
>
__access_restrictions
>
> -/* Update the access rights for the current thread for KEY, which must
> +/* Update the access restrictions for the current thread for KEY, which
> must
> have been allocated using pkey_alloc. */
> -int pkey_set (int __key, unsigned int __access_rights) __THROW;
> +int pkey_set (int __key, unsigned int __restrictions) __THROW;
>
__access_restrictions
>
> -/* Return the access rights for the current thread for KEY, which must
> +/* Return the restrictions for the current thread for KEY, which must
>
I think we should use "access restrictions" here.
> have been allocated using pkey_alloc. */
> int pkey_get (int __key) __THROW;
>
> diff --git a/sysdeps/unix/sysv/linux/pkey_set.c
> b/sysdeps/unix/sysv/linux/pkey_set.c
> index 30463ef89b..cd1f806803 100644
> --- a/sysdeps/unix/sysv/linux/pkey_set.c
> +++ b/sysdeps/unix/sysv/linux/pkey_set.c
> @@ -20,7 +20,7 @@
> #include <sys/mman.h>
>
> int
> -__pkey_set (int key, unsigned int access_rights)
> +__pkey_set (int key, unsigned int restrictions)
>
access_restrictions
> {
> __set_errno (ENOSYS);
> return -1;
> --
> 2.39.5
>
>
--
Joe Simmons-Talbott
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://sourceware.org/pipermail/libc-alpha/attachments/20241022/c40752dd/attachment.htm>
More information about the Libc-alpha
mailing list