[PATCH 2/2] clock_nanosleep.2, nanosleep.2: Use 'duration' rather than 'request'
Alejandro Colomar
alx@kernel.org
Tue Mar 5 01:11:39 GMT 2024
On Mon, Mar 04, 2024 at 04:56:13PM -0800, enh wrote:
> > > int clock_nanosleep(clockid_t __clock, int __flags, const struct
> > > timespec* _Nonnull __time, struct timespec* _Nullable __remainder);
> >
> > Hmmmm, that's the best name, meaningfully, I think. But I've been
> > trying to avoid it. I don't like using names of standard functions in
> > identifiers; it might confuse. As an alternative, I thought of 't'.
> > What do you think?
>
> as you can see, i've taken the "the leading `__` means we get to
> trample whatever we like" approach :-)
>
> (we build bionic with hidden visibility and an explicit list of
> symbols for the linker to export, so we'd have to be trying quite hard
> to trip over ourselves.)
Yeah, I was worried about the manual page :)
--
<https://www.alejandro-colomar.es/>
Looking for a remote C programming job at the moment.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <https://sourceware.org/pipermail/libc-alpha/attachments/20240305/2b7d9f65/attachment.sig>
More information about the Libc-alpha
mailing list