[PATCH v2 4/4] c2y: Add function cnd_timedwait_base and mtx_timedlock_base
Xi Ruoyao
xry111@xry111.site
Wed Jun 21 09:54:29 GMT 2023
On Wed, 2023-06-21 at 17:21 +0800, 罗勇刚(Yonggang Luo) via Libc-alpha
wrote:
> The function name was suggested by Jens Gustedt, and indeed I also thought
> about this name in the first place(because posix has cond_clockwait and
> mutex_clocklock already). And seems enh also like this
>
> If we have minimal agreement about this proposal, I'd like to add tests for
> it. But still, I don't think
> __USE_GNU is a good name for it, because it's for C2y or C3x, any better
> option for this, so that it's not GNU restricted, for example, suppose MSVC
> also wants to implement this?
No, __USE_GNU does not mean it's GNU restricted, but mean it's a GNU
extension. Other implementations can implement GNU extensions as well
if they wish (and doing so does not violate LGPL unless they copy the
implementation from Glibc).
Hmm, and do you have some misunderstanding about the relationship betwen
the C standard and Glibc? Glibc implements the standard, but it's not
the standard. If you want to add the functions into the standard you
need to submit it to WG14 first. Before WG14 accept it, we cannot
declare the functions standard. I've not seen your paper at
https://www.open-std.org/jtc1/sc22/wg14/www/wg14_document_log.htm but
maybe I missed something.
--
Xi Ruoyao <xry111@xry111.site>
School of Aerospace Science and Technology, Xidian University
More information about the Libc-alpha
mailing list