[PATCH 0/3] More getaddrinfo refactoring

Siddhesh Poyarekar siddhesh@sourceware.org
Mon Mar 14 17:30:36 GMT 2022


These are refactoring patches in parts of getaddrinfo implementation other than
gaih_inet, aimed at improving readability of the code.

Tested with x86_64 and i686 build and check.

Siddhesh Poyarekar (3):
  gaiconf_init: Refactor some bits for readability
  gai_init: Avoid jumping from if condition to its else counterpart
  getaddrinfo: Refactor code for readability

 sysdeps/posix/getaddrinfo.c | 651 +++++++++++++++++++-----------------
 1 file changed, 345 insertions(+), 306 deletions(-)

-- 
2.35.1



More information about the Libc-alpha mailing list