[PATCH] elf: Rename tst-audit26 to tst-audit28
Florian Weimer
fweimer@redhat.com
Fri Jul 8 11:46:18 GMT 2022
tst-audit26 and tst-audit27 are already used by aarch64.
Tested on aarch64-linux-gnu, i686-linux-gnu, x86_64-linux-gnu. I think
this change is sufficient because the next architecture-independent test
will probably be called tst-audit29, so it is unlikely that the same
name conflict will be introduced.
---
elf/Makefile | 10 +++++-----
elf/{tst-audit26.c => tst-audit28.c} | 0
elf/{tst-auditmod26.c => tst-auditmod28.c} | 0
3 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/elf/Makefile b/elf/Makefile
index 2b646a91e0..fd77d0c7c8 100644
--- a/elf/Makefile
+++ b/elf/Makefile
@@ -394,7 +394,7 @@ tests += \
tst-audit24d \
tst-audit25a \
tst-audit25b \
- tst-audit26 \
+ tst-audit28 \
tst-auditmany \
tst-auxobj \
tst-auxobj-dlopen \
@@ -816,7 +816,7 @@ modules-names += \
tst-auditmod24c \
tst-auditmod24d \
tst-auditmod25 \
- tst-auditmod26 \
+ tst-auditmod28 \
tst-auxvalmod \
tst-big-note-lib \
tst-deep1mod1 \
@@ -2358,9 +2358,9 @@ $(objpfx)tst-audit25b: $(objpfx)tst-audit25mod1.so \
LDFLAGS-tst-audit25b = -Wl,-z,now
tst-audit25b-ARGS = -- $(host-test-program-cmd)
-$(objpfx)tst-audit26.out: $(objpfx)tst-auditmod26.so
-$(objpfx)tst-auditmod26.so: $(libsupport)
-tst-audit26-ENV = LD_AUDIT=$(objpfx)tst-auditmod26.so
+$(objpfx)tst-audit28.out: $(objpfx)tst-auditmod28.so
+$(objpfx)tst-auditmod28.so: $(libsupport)
+tst-audit28-ENV = LD_AUDIT=$(objpfx)tst-auditmod28.so
# tst-sonamemove links against an older implementation of the library.
LDFLAGS-tst-sonamemove-linkmod1.so = \
diff --git a/elf/tst-audit26.c b/elf/tst-audit28.c
similarity index 100%
rename from elf/tst-audit26.c
rename to elf/tst-audit28.c
diff --git a/elf/tst-auditmod26.c b/elf/tst-auditmod28.c
similarity index 100%
rename from elf/tst-auditmod26.c
rename to elf/tst-auditmod28.c
More information about the Libc-alpha
mailing list