[PATCH 4/7] Move libc_freeres_ptrs and libc_subfreeres to weak functions
Adhemerval Zanella Netto
adhemerval.zanella@linaro.org
Mon Dec 12 13:16:24 GMT 2022
On 12/12/22 07:58, Florian Weimer wrote:
> * Adhemerval Zanella via Libc-alpha:
>
>> diff --git a/elf/dl-libc.c b/elf/dl-libc.c
>> index 266e068da6..06bce2f6dd 100644
>> --- a/elf/dl-libc.c
>> +++ b/elf/dl-libc.c
>> @@ -228,7 +228,7 @@ __libc_dlclose (void *map)
>> }
>>
>>
>> -static bool __libc_freeres_fn_section
>> +static bool
>> free_slotinfo (struct dtv_slotinfo_list **elemp)
>> {
>> size_t cnt;
>> @@ -256,7 +256,7 @@ free_slotinfo (struct dtv_slotinfo_list **elemp)
>> }
>>
>>
>> -libc_freeres_fn (free_mem)
>> +void __libc_freemem (void)
>> {
>> struct link_map *l;
>> struct r_search_path_elem *d;
>
> I believe this should be called __dl_libc_freemem or something like
> that, to point towards dl-libc.c as the implementing file.
Alright, I will rename it.
More information about the Libc-alpha
mailing list