[PATCH v6] String: Add support for __memcmpeq() ABI on all targets

Florian Weimer fweimer@redhat.com
Wed Sep 29 09:44:36 GMT 2021


* Andreas Schwab:

> On Sep 29 2021, Florian Weimer wrote:
>
>> * Andreas Schwab:
>>
>>> How about calling the function __memequal?
>>
>> Programmers tend to use memequal for functions which return 0 for
>> different inputs:
>
> __memcmpeq has the same problem.

I don't see it.  The examples in

  <https://codesearch.debian.net/search?q=memcmpeq&literal=1>

all use the inverted sense of memcmp/bcmp.

Thanks,
Florian



More information about the Libc-alpha mailing list