[PATCH 0/5] getaddrinfo spaghetti cleanups

Siddhesh Poyarekar siddhesh@sourceware.org
Tue Aug 3 21:29:14 GMT 2021


This series cleans up a bunch of confusing gotos in various functions in
getaddrinfo.  The gotos jump from one condition to another and in
various directions, making code quite hard to read.

Siddhesh Poyarekar (5):
  gaiconf_init: Refactor some bits for readability
  gai_init: Avoid jumping from if condition to its else counterpart
  getaddrinfo: Refactor code for readability
  gaih_inet: Consolidate got_port code
  gaih_inet: Make process_list label into a function

 sysdeps/posix/getaddrinfo.c | 1067 ++++++++++++++++++-----------------
 1 file changed, 542 insertions(+), 525 deletions(-)

-- 
2.31.1



More information about the Libc-alpha mailing list