/usr/include/aio.h

Jonny Grant jg@jguk.org
Sat Oct 3 22:02:10 GMT 2020


Hello

Just wondering :

a) why there are these macros like AIO_ALLDONE below? Surely the enum is enough.

b) why the enum's aren't numbered, so when looking in a debugger it's easier to follow the number back to this header file

/* Return values of cancelation function.  */
enum
{
  AIO_CANCELED,
#define AIO_CANCELED AIO_CANCELED
  AIO_NOTCANCELED,
#define AIO_NOTCANCELED AIO_NOTCANCELED
  AIO_ALLDONE
#define AIO_ALLDONE AIO_ALLDONE
};


Cheers, Jonny


More information about the Libc-alpha mailing list