[PATCH 1/2] y2038: linux: Provide __mq_timedsend_time64 implementation
Lukasz Majewski
lukma@denx.de
Wed Feb 12 14:52:00 GMT 2020
Hi Andreas,
> On Feb 12 2020, Lukasz Majewski wrote:
>
> > The question is about naming convention -
> >
> > include/bits/types/struct_timespec.h -> suggest that we do have here
> > the "internal" re-definition of struct timespec but IMHO we do
> > introduce another "internal type" - namely struct __timespec64
> >
> > Hence the below code shall be put to:
> > include/bits/types/struct__timespec64.h
>
> That would be ok with me either way.
>
> Andreas.
>
The same code put into include/bits/types/struct___timespec64.h file
requires having the explicit #include in ./include/time.h (and
mqueue.h).
However, it works correctly (i.e. is included automatically) only when
put into include/bits/types/struct_timespec.h
I need to investigate it further...
Best regards,
Lukasz Majewski
--
DENX Software Engineering GmbH, Managing Director: Wolfgang Denk
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-59 Fax: (+49)-8142-66989-80 Email: lukma@denx.de
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 488 bytes
Desc: OpenPGP digital signature
URL: <http://sourceware.org/pipermail/libc-alpha/attachments/20200212/ac8674be/attachment.sig>
More information about the Libc-alpha
mailing list