[v2, with help] Re: run one test
Carlos O'Donell
carlos@redhat.com
Mon Sep 30 20:51:00 GMT 2019
On 9/30/19 3:58 PM, DJ Delorie wrote:
> "Carlos O'Donell" <carlos@redhat.com> writes:
>> Bikeshed. Suggest "onecheck" alias given that 'make test' is the same
>> as 'make check.'
>
> Can add. I was thinking we already have "make nss/tests" and "make
> tests", we call them "tests" and "testsuite", and "make check" is just a
> convenience target:
>
> # Support the GNU standard name for this target.
> .PHONY: check
> check: tests
>
> Or we could call it "make test" (note singular) but I suspect this would
> be confusing, and "make check" (note singular!) vs "make checks".
In summary:
make check = make tests
make onecheck = make test
Or is the tests vs test too confusing?
--
Cheers,
Carlos.
More information about the Libc-alpha
mailing list