[PATCH] sysdeps/riscv/start.S: rename .Lload_gp to load_gp (bug 24376)

Zack Weinberg zackw@panix.com
Tue Sep 24 13:24:00 GMT 2019


On Tue, Sep 24, 2019 at 9:23 AM Andreas Schwab <schwab@suse.de> wrote:
> On Sep 24 2019, Florian Weimer <fw@deneb.enyo.de> wrote:
> > * Andreas Schwab:
> >> Renaming the symbol keeps the label in the symbol table as a normal local
> >> label, so that `objdump -d' can pick it up as an anchor.
> >
> > Perhaps use startup_load_gp instead, so that it's less ambiguous in
> > the debugging information?
>
> It's a local label, so no conflict possible.

That's not what he was saying.

zw



More information about the Libc-alpha mailing list