[PATCH v2] sysdeps/posix: Simplify if expression in getaddrinfo()
Tim Rühsen
tim.ruehsen@gmx.de
Sun Nov 24 19:35:00 GMT 2019
Small code cleanup for better readability.
---
sysdeps/posix/getaddrinfo.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/sysdeps/posix/getaddrinfo.c b/sysdeps/posix/getaddrinfo.c
index ea127877cb..afdcdf0a3b 100644
--- a/sysdeps/posix/getaddrinfo.c
+++ b/sysdeps/posix/getaddrinfo.c
@@ -2206,7 +2206,7 @@ getaddrinfo (const char *name, const char *service,
{
/* If we haven't seen both IPv4 and IPv6 interfaces we can
narrow down the search. */
- if ((! seen_ipv4 || ! seen_ipv6) && (seen_ipv4 || seen_ipv6))
+ if (seen_ipv4 != seen_ipv6)
{
local_hints = *hints;
local_hints.ai_family = seen_ipv4 ? PF_INET : PF_INET6;
--
2.24.0
More information about the Libc-alpha
mailing list