systemd-nspawn (at least the Fedora version) applies a system call filter which causes system calls to fail with EPERM instead of ENOSYS. This breaks our fallback handling. This problem has existed for a long time, but it has become more prevalent with the recent time64 changes. I think this is a systemd-nspawn bug. Thanks, Florian