[RFC 5/7] y2038: clock_settime: implementation for Unix generic

Joseph Myers joseph@codesourcery.com
Wed Mar 27 17:00:00 GMT 2019


On Wed, 27 Mar 2019, Lukasz Majewski wrote:

> * sysdeps/unix/clock_settime (hp_timing_settime):
>   Use __timespec64 in function prototype
> * sysdeps/unix/clock_settime: Rename __clock_settime to __clock_settime64
> * sysdeps/unix/clock_settime: Remove weak_alias for __clock_settime
> * sysdeps/unix/clock_settime: Add clock_settime when __TIMESIZE != 64

Please write an actual textual explanation, however many paragraphs are 
needed, for each patch.  Not just the ChangeLog entry.  There are various 
formatting issues with this ChangeLog entry, but the textual description 
is what's needed first for review.

(You should also, for every patch, give details of how it was tested, on 
at least one 32-bit and at least one 64-bit architecture, with the full 
glibc testsuite without causing any regressions.  If the code being 
changed is generic code not actually used for any glibc configuration, 
please say so.  In the case of this patch, the code is used *only* for 
Hurd, as systems using the Linux kernel use 
sysdeps/unix/sysv/linux/clock_settime.c.  Thus, you should at least 
compile and run the compilation tests for i686-gnu for this patch, using 
build-many-glibcs.py, and report on that verification in the proposed 
commit message.)

-- 
Joseph S. Myers
joseph@codesourcery.com



More information about the Libc-alpha mailing list