[PATCH v4 00/12] nptl: Implement POSIX-proposed _clock variants of existing _timed functions
Adhemerval Zanella
adhemerval.zanella@linaro.org
Tue Jun 25 22:13:00 GMT 2019
On 18/06/2019 13:33, Mike Crowe wrote:
> My attempts[1] to add a variant of pthread_cond_timedwait that would accept
> a clockid_t parameter led me to propose[2] to The Austin Group the addition
> of an entire family of functions that accept a clockid_t parameter to
> indicate the clock that the timespec absolute timeout parameter should be
> measured against. They responded positively to the request but an
> implementation is required before the proposal can proceed.
>
> This patch series is the second version of the first part of that
> implementation in glibc, it contains implementations and tests for
> four new functions:
>
> int pthread_cond_clockwait(pthread_cond_t *cond, pthread_mutex_t *mutex,
> clockid_t clock, const struct timespec *abstime)
>
> int pthread_rwlock_clockrdlock(pthread_rwlock_t *rwlock, clockid_t clock,
> const struct timespec *abstime)
>
> int pthread_rwlock_clockwrlock(pthread_rwlock_t *rwlock, clockid_t clock,
> const struct timespec *abstime)
>
> int sem_clockwait(sem_t *restrict, clockid_t clock_id, const struct
> timespec *restrict)
>
> int pthread_mutex_clocklock (pthread_mutex_t *mutex,
> clockid_t clockid,
> const struct timespec *abstime)
Hi Mike,
I have created a personal branch [1] with remaining patches with the small
fixes I pointed on the review. It just to make it simpler you give me ack
and avoid resending all the patch all over again.
Florian, I am using the original naming scheme as indicated above. I think
we should follow what is expected from standard once we have an actual
implementation.
[1] https://sourceware.org/git/?p=glibc.git;a=shortlog;h=refs/heads/azanella/master-posix_clock
More information about the Libc-alpha
mailing list