[PATCH v1 3/4] nptl: Rename lll_timedlock to lll_clocklock and add clockid parameter

Mike Crowe mac@mcrowe.com
Tue Jun 18 10:28:00 GMT 2019


On Wednesday 05 June 2019 at 09:47:07 -0300, Adhemerval Zanella wrote:
> 
> 
> On 03/06/2019 09:15, Mike Crowe wrote:
> > Rename lll_timedlock to lll_clocklock and add clockid
> > parameter to indicate the clock that the abstime parameter should
> > be measured against in preparation for adding
> > pthread_mutex_clocklock.
> 
> I don't see really a gain in change an internal definition name, I think
> we can use the current name and just add the extra parameter.

I changed the name to mirror the naming of the visible functions and make
it clear which functions take the extra clock parameter:

 timed => absolute timeout measured against CLOCK_REALTIME (or clock
          specified by attribute in the case of pthread_cond_timedwait.)

 clock => absolute timeout measured against clock specified in preceding
          parameter.

But, if there is agreement that this renaming is unnecessary, then I can
undo it.

[snip other review comment that I will address]

Thanks.

Mike.



More information about the Libc-alpha mailing list