[PATCH v4 01/13] C-SKY: ABI related code

Mao Han han_mao@c-sky.com
Tue Sep 18 06:09:00 GMT 2018


On Mon, Sep 17, 2018 at 09:45:55PM +0000, Joseph Myers wrote:
> On Wed, 12 Sep 2018, Mao Han wrote:
> 
> > +/* The canonical name for the function is `_mcount' in both C and asm,
> > +   but some old asm code might assume it's `mcount'.  */
> > +#undef mcount
> > +weak_alias (_mcount, mcount)
> 
> That may be a reason to have this for old architectures, but you shouldn't 
> have old asm for a new architecture, so no need for an mcount alias.
>

Yes. No need to keep this, will remove.

Thanks,
Han Mao 



More information about the Libc-alpha mailing list