[PATCH v10] Mutex: Add pthread mutex tunables

Carlos O'Donell carlos@redhat.com
Fri Nov 30 22:04:00 GMT 2018


On 11/30/18 3:12 AM, Kemi Wang wrote:
> ChangeLog:
> 	V9->V10:
> 	a) Remove superfluous comments, as suggested by Adhemerval Zanella
> 	b) Use max_adaptive_count() to get the maximum spin count, as suggested
> 	by Adhemerval Zanella
> 	c) Move DEFAULT_ADAPTIVE_COUNT definition to a generic header and
> 	override this header by the architecture in future, as suggested by
> 	Adhemerval Zanella
> 	d) Use macro DEFAULT_ADAPTIVE_COUNT to replace magic number 100, as
> 	suggested by Carlos
> 	e) Other minor change on tunable description, as suggested by Carlos
> 	f) Change maximum value of adaptive spin count from 30000 to 32767(full
> 	short range), as suggested by Adhemerval Zanella.
> 	g) Move "struct mutex_config" definition back to pthread_mutex_conf.h,
> 	thus, the header pthreadP.h does not have to be included in
> 	pthread_mutex_conf.c

I just wanted to publicly thank you for going 10 iterations to get this
patch into the state that it is in today. I appreciate your patience,
professionalism, and attention to detail. I hope to review more of your
patches in the future :-)

-- 
Cheers,
Carlos.



More information about the Libc-alpha mailing list