[PATCH] Move M_DECL_FUNC_R* to math-type-macros.h
Joseph Myers
joseph@codesourcery.com
Fri May 11 19:49:00 GMT 2018
On Fri, 11 May 2018, Tulio Magno Quites Machado Filho wrote:
> Thread-safe math functions (*_r) have a different naming scheme that
> doesn't fit the M_SUF() / M_DECL_FUNC() mechanism.
> Move the M_DECL_FUNC_R() implementation from w_lgamma_r_template.c to
> math-type-macros.h in order to reuse these macros in other functions.
lgamma_r is a pretty unique function and I don't see any likely other such
functions (at all, whether or not they might be implemented with
type-generic templates). So again, you'll need to explain more why this
is useful (or if it's just intended as a cleanup, I think such a cleanup
should make the _r an explicit macro argument so M_DECL_FUNC can be
defined in terms of M_DECL_FUNC_R, just as libm_alias_float is defined in
terms of libm_alias_float_r, etc., unless there's some reason that can't
work).
--
Joseph S. Myers
joseph@codesourcery.com
More information about the Libc-alpha
mailing list