[PATCH 6/7] sin/cos slow paths: refactor duplicated code into dosin
Joseph Myers
joseph@codesourcery.com
Thu Mar 22 22:34:00 GMT 2018
On Wed, 21 Mar 2018, Wilco Dijkstra wrote:
> Refactor duplicated code into do_sin. Since all calls to do_sin use copysign to
> set the sign of the result, move it inside do_sin. Small inputs use a separate
> polynomial, so move this into do_sin as well (the check is based on the more
> conservative case when doing large range reduction, but could be relaxed).
OK.
--
Joseph S. Myers
joseph@codesourcery.com
More information about the Libc-alpha
mailing list