On Mon, 5 Mar 2018, Samuel Thibault wrote: > +#ifndef __struct_sigaction_defined > +#define __struct_sigaction_defined 1 I don't think this is an appropriate guard for a header that defines more than just struct sigaction; I think you should use _BITS_SIGACTION_H in this case. -- Joseph S. Myers joseph@codesourcery.com