[PATCH] gethostid (Linux variant): Switch to struct scratch_buffer [BZ #18023]

DJ Delorie dj@redhat.com
Tue Jun 26 18:16:00 GMT 2018


fweimer@redhat.com (Florian Weimer) writes:
>	[BZ #18023]
>	* sysdeps/unix/sysv/linux/gethostid.c (gethostid): Use struct
>	scratch_buffer instead of extend_alloca.  Update comments.

LGTM

A question about style, though... you have an if/else inside an else{}
block.  Would it be more readable to do if {} elseif {} else {} instead?



More information about the Libc-alpha mailing list