Put CPU-related tunables into a unique namespace?

Siddhesh Poyarekar siddhesh@gotplt.org
Thu Jul 12 18:28:00 GMT 2018


On 07/12/2018 11:07 PM, Carlos O'Donell wrote:
> On 07/12/2018 12:23 PM, Siddhesh Poyarekar wrote:
>> On 07/12/2018 09:01 PM, Carlos O'Donell wrote:
>>> OK, so a couple of questions for you?
>>>
>>> * Should '.tune.' be removed considering these are *tunables*?
>>
>> The 'tune' meant 'CPU tuning' for me when I had proposed it, so it
>> isn't quite the same as 'tunable'.  Maybe call it 'perf' since
>> they're all performance related?
>>
>> Or maybe glibc.cpu.* and then rename glibc.tune.cpu to
>> glibc.cpu.name?
> 
> Sure! I like that.

Cool, I'll post a patch for this next week if nobody objects to the idea 
till then.

Siddhesh



More information about the Libc-alpha mailing list