[PATCH 1/2] Revert and update "Revert Intel CET changes to __jmp_buf_tag (Bug 22743)"

H.J. Lu hjl.tools@gmail.com
Thu Feb 8 18:39:00 GMT 2018


On Thu, Feb 8, 2018 at 5:27 AM, H.J. Lu <hjl.tools@gmail.com> wrote:
> On Thu, Feb 8, 2018 at 1:25 AM, Carlos O'Donell <carlos@redhat.com> wrote:
ils:
>>
>> The name NEED_SAVED_MASK_IN_CANCEL_JMP_BUF while true is slightly
>> misleading IMO. While it is true that you need the saved mask there, the
>> actual logical goal is to make the structure match in layout with the
>> non-cancel jmp_buf. I would rename this to NEED_SETJMP_LAYOUT or something
>
> Will do.
>

Here is the updated patch to revert

commit 2ec0e7eade0ea1258acd5c6f5e5e9bfaeb5041a8
Author: Carlos O'Donell <carlos@systemhalted.org>
Date:   Wed Jan 24 20:35:22 2018 -0800

    Revert Intel CET changes to __jmp_buf_tag (Bug 22743)

OK for trunk?

Thanks.

-- 
H.J.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-Revert-and-update-Revert-Intel-CET-changes-to-__jmp_.patch
Type: text/x-patch
Size: 13504 bytes
Desc: not available
URL: <http://sourceware.org/pipermail/libc-alpha/attachments/20180208/7f3d879f/attachment.bin>


More information about the Libc-alpha mailing list