[PATCH] nss_files: Use struct scratch_buffer for gethostbyname [BZ #18023]

Florian Weimer fweimer@redhat.com
Tue Oct 10 13:02:00 GMT 2017


On 09/05/2017 08:38 PM, Florian Weimer wrote:

>> I do think this it is easier to read and follow the code *without* the goto,
>> something like:
>>
>> scratch_buffer_init (...);
>> while (1)
>>    {
>>      while ((status = internal_getent (...)) == NSS_STATUS_SUCCESS)
>>        {
>>          ...
>>        }
>>      if (status == NSS_STATUS_TRYAGAIN)
>>        if (!scratch_buffer_grow (&tmp_buffer))
>>          {
>>            *herrnop = NETDB_INTERNAL;
>>            status = NSS_STATUS_TRYAGAIN;
>>            break;
>>          }
>>      else
>>        status = NSS_STATUS_SUCCESS;
>>    }
>> scratch_buffer_free (...);
> 
> Right, I think I'll make this change in the first (refactoring) patch.

I made this change in this patch instead.  Still okay?

Thanks,
Florian
-------------- next part --------------
A non-text attachment was scrubbed...
Name: bug18023.patch
Type: text/x-patch
Size: 11053 bytes
Desc: not available
URL: <http://sourceware.org/pipermail/libc-alpha/attachments/20171010/00964dfd/attachment.bin>


More information about the Libc-alpha mailing list