[PATCH] Consolidate Linux mmap implementation

Adhemerval Zanella adhemerval.zanella@linaro.org
Fri Mar 24 17:57:00 GMT 2017



On 24/03/2017 14:42, Andreas Schwab wrote:
> On Mär 24 2017, Adhemerval Zanella <adhemerval.zanella@linaro.org> wrote:
> 
>> +void *
>> +__mmap (void *addr, size_t len, int prot, int flags, int fd, off_t offset)
>> +{
>> +  MMAP_CHECK_PAGE_UNIT
> 
> I think it would be better to define this as a function style macro.
> 
> Andreas.
> 

I do not have preference here, I changed to:

# define MMAP_CHECK_PAGE_UNIT() ...



More information about the Libc-alpha mailing list