On 06/08/2017 11:13 PM, Adhemerval Zanella wrote: > +#ifdef CMDLINE_OPTSTRING > + test_config.optstring = CMDLINE_OPTSTRING; > +#else > + test_config.optstring = "+"; Why not "+" CMDLINE_OPTSTRING, for consistency? Otherwise, this looks good to me. Thanks, Florian