[PATCH] support: Add TEST_COMPARE macro
Paul Eggert
eggert@cs.ucla.edu
Mon Dec 4 19:23:00 GMT 2017
On 12/04/2017 08:35 AM, Florian Weimer wrote:
> + __left_converts_to_right = __left_is_unsigned \
> + && sizeof (__left_value) < sizeof (__right_value), \
Thanks, this implementation looks good. Two minor style issues. First,
please indent this decl according to the usual glibc style, where
multiline expressions are parenthesized (or perhaps you can put the " =
" on the next line). Second, I suggest changing the name from
"__left_converts_to_right" to "__unsigned_left_converts_to_wider", as
this more-accurately describes the expression (as there are cases where
the left's value is converted to the right's type but
__left_converts_to_right is false). Similarly for
__right_converts_to_left of course.
More information about the Libc-alpha
mailing list