[PATCH 3/5] Consolidate input partitioning into do_cos and do_sin
Joseph Myers
joseph@codesourcery.com
Thu Sep 1 16:23:00 GMT 2016
On Tue, 23 Aug 2016, Siddhesh Poyarekar wrote:
> All calls to do_cos are preceded by code that partitions x into a
> larger double that gives an offset into the sincos table and a smaller
> double that is used in a polynomial computation. Consolidate all of
> them into do_cos and do_sin to reduce code duplication.
>
> * sysdeps/ieee754/dbl-64/s_sin.c (do_cos): Accept X and DX as input
> arguments. Consolidate input partitioning from callers here.
> (do_cos_slow): Likewise.
> (do_sin): Likewise.
> (do_sin_slow): Likewise.
> (do_sincos_1): Remove the no longer necessary input partitioning.
> (do_sincos_2): Likewise.
> (__sin): Likewise.
> (__cos): Likewise.
> (slow1): Likewise.
> (slow2): Likewise.
> (sloww1): Likewise.
> (sloww2): Likewise.
> (bsloww1): Likewise.
> (bsloww2): Likewise.
> (cslow2): Likewise.
OK.
--
Joseph S. Myers
joseph@codesourcery.com
More information about the Libc-alpha
mailing list