[PATCH 1/6] ldbl-128: Simplify fma usage

Paul E. Murphy murphyp@linux.vnet.ibm.com
Wed Aug 17 19:24:00 GMT 2016



On 08/16/2016 01:03 PM, Joseph Myers wrote:
> On Tue, 16 Aug 2016, Paul E. Murphy wrote:
> 
>> Several ldbl-128 files share identical code which does
>> not ammend itself to the macro renaming necessary to
>> support building with another type.
>>
>> This moves the duplicated function mul_split into its
>> own header, and refactors the fma usage into a single
>> selection macro.
> 
> This seems like something that if done for one type, should be done for 
> all types together (optionally also removing the "compiler before GCC 4.6" 
> cases as no longer relevant to building glibc).
> 

This expands it to the users in ldbl-128ibm, dbl-64, and ldbl-96.  Likewise,
the long double mul_split is renamed mul_splitl for clarity.

The new headers are also moved into math/ to reflect the shared usage.

I've verified the generated code for x86_64, ppc64, s390x, and aarch64 libm
has not changed.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-Merge-common-usage-of-mul_split-function.patch
Type: text/x-patch
Size: 24744 bytes
Desc: not available
URL: <http://sourceware.org/pipermail/libc-alpha/attachments/20160817/ba09adef/attachment.bin>


More information about the Libc-alpha mailing list