> On 03/28/2016 08:19 AM, Adhemerval Zanella wrote: > > + s = (unsigned char *) ((size_t)s & ~3); > > Nit: s/size_t/uintptr_t/. > > It's the same type for all supported targets, > but the spelling says what you mean. libc-internal.h has PTR_ALIGN_DOWN for this.