[PATCH 1/6] Add INLINE_SYSCALL_ERROR_RETURN
Florian Weimer
fweimer@redhat.com
Tue Oct 13 12:38:00 GMT 2015
On 10/13/2015 01:19 AM, H.J. Lu wrote:
> +/* Set error number and return -1. A target may choose to return the
> + internal function, __syscall_error, which sets errno and returns -1. */
> +#define INLINE_SYSCALL_ERROR_RETURN(err) \
> + ({ \
> + __set_errno (err); \
> + -1; \
> + })
I think the name is unfortunate because it the macro does not contain a
return statement.
Perhaps INLINE_SYSCALL_SET_ERRNO would be a better name?
Florian
More information about the Libc-alpha
mailing list