[PATCH 11/13] nptl: arm: Fix Race conditions in pthread cancellation (BZ#12683)
Phil Blundell
pb@pbcl.net
Thu Oct 8 15:29:00 GMT 2015
On Wed, 2015-10-07 at 13:23 -0300, Adhemerval Zanella wrote:
> From: Adhemerval Zanella <adhemerval.zanella@linaro.org>
>
> This patch adds the ARM modifications required for the BZ#12683 fix.
> It basically removes the enable_asynccancel/disable_asynccancel
> function
> usage on code, provide a arch-specific symbol that contains global
> markers to be used in SIGCANCEL handler.
>
> Checked on armhf.
What architecture variant specifically? Have you verified that this at
least compiles on older arches? (I think we still support everything
back to ARMv4.)
>
+ PSEUDO_CANCEL_BEFORE;
> \
> + ldr r0, =SYS_ify (syscall_name);
> \
> + PSEUDO_CANCEL_AFTER;
>
It's still not very clear to me that the PSEUDO_CANCEL_BEFORE and
PSEUDO_CANCEL_AFTER macros are achieving anything other than making the
code harder to read. Is there any reason these couldn't just be
written in line?
p.
More information about the Libc-alpha
mailing list