[PATCH v3 1/3] Consolidate vDSO macros and usage
Nathan Lynch
Nathan_Lynch@codesourcery.com
Tue May 19 19:49:00 GMT 2015
On 05/11/2015 02:11 PM, Adhemerval Zanella wrote:
> This patch consolidate the Linux vDSO define and usage across all ports
> that uses it. The common vDSO definitions and calling through
> {INLINE/INTERNAL}_VSYSCALL macros are moved to a common header
> sysdep-vdso.h and vDSO name declaration and prototype is defined
> using a common macro.
>
> Also PTR_{MANGLE,DEMANGLE} is added to ports that does not use them
> for vDSO calls (aarch64, powerpc, s390, and tile) and thus it will
> reflect in code changes. For ports that already implement pointer
> mangling/demangling in vDSO system (i386, x32, x86_64) this patch
> is mainly a code refactor.
>
> Checked on x32, x86_64, x32, ppc64le, and aarch64. Ok to apply?
>
> Changes from previous version:
>
> - Rename INTERNAL_VSYSCALL_NCS to INTERNAL_VSYSCALL_CALL on all
> ports.
I believe this series leaves a stray definition of INTERNAL_VSYSCALL_NCS
in aarch64:
/* List of system calls which are supported as vsyscalls. */
# define HAVE_CLOCK_GETRES_VSYSCALL 1
# define HAVE_CLOCK_GETTIME_VSYSCALL 1
# define HAVE_GETTIMEOFDAY_VSYSCALL 1
# define INTERNAL_VSYSCALL_NCS(funcptr, err, nr, args...) \
Otherwise it looks fine to me and I have reworked the ARM VDSO support
patch on top of it.
More information about the Libc-alpha
mailing list