Florian Weimer wrote: > # define INT_T int > +typedef const char *THOUSANDS_SEP_T; A nit: if the name's not a macro, I'd keep it lower-case. Upper-case is for shouting "WATCH OUT! I LOOK LIKE A NORMAL NAME, BUT I ACTUALLY AM A MACRO!"