search locale archive again after alias expansion
Andreas Schwab
schwab@suse.de
Mon Mar 2 08:21:00 GMT 2015
Alexandre Oliva <aoliva@redhat.com> writes:
> On Feb 26, 2015, Andreas Schwab <schwab@suse.de> wrote:
>
>> Alexandre Oliva <aoliva@redhat.com> writes:
>>> - loc_name = strdupa (loc_name);
>>> + char *loc_name = strdupa (cloc_name);
>
>> If you rename this to loc_name_copy, instead of the other way round, you
>> get nicer variable names, and a smaller delta as a bonus.
>
> Yeah, but that wouldn't have made it crystal clear that no uses of the
> original loc_name remained in the affected range ;-)
That wouldn't work either way.
Andreas.
--
Andreas Schwab, SUSE Labs, schwab@suse.de
GPG Key fingerprint = 0196 BAD8 1CE9 1970 F4BE 1748 E4D4 88E3 0EEA B9D7
"And now for something completely different."
More information about the Libc-alpha
mailing list