[COMMITTED PATCH] NPTL: Use unsigned type for setxid_futex.
Roland McGrath
roland@hack.frob.com
Thu Jun 25 15:14:00 GMT 2015
Verified on x86_64-linux-gnu that no generated code changes at all.
A good follow-up cleanup here would be to replace the four magic values
used throughout the code (0, 1, -1, -2) with an enum.
Thanks,
Roland
* nptl/descr.h (struct pthread): Change type of field setxid_futex
to 'unsigned int'.
diff --git a/nptl/descr.h b/nptl/descr.h
index 5bd1282..a502048 100644
--- a/nptl/descr.h
+++ b/nptl/descr.h
@@ -328,7 +328,7 @@ struct pthread
int lock;
/* Lock for synchronizing setxid calls. */
- int setxid_futex;
+ unsigned int setxid_futex;
#if HP_TIMING_AVAIL
/* Offset of the CPU clock at start thread start time. */
More information about the Libc-alpha
mailing list