[PATCH] Use "_" prefix for macro variables, and harmonize variable names for sysdep syscall macros.

Andreas Schwab schwab@linux-m68k.org
Fri Jun 12 14:09:00 GMT 2015


"Carlos O'Donell" <carlos@redhat.com> writes:

> +	register unsigned long _sc_ret asm("r28");			\
> +	PIC_REG_DEF							\
> +	LOAD_ARGS_##nr(args)						\
> +	/* FIXME: HACK save/load r19 around syscall */			\
> +	asm volatile(							\
> +		SAVE_ASM_PIC						\
> +		"	ble  0x100(%%sr2, %%r0)\n"			\
> +		"	ldi %1, %%r20\n"				\
> +		LOAD_ASM_PIC						\
> +		: "=r" (_sc_ret)					\
> +		: "i" (SYS_ify(name)) PIC_REG_USE ASM_ARGS_##nr		\
> +		: "memory", CALL_CLOB_REGS CLOB_ARGS_##nr		\
> +	);								\
> +	if ( (unsigned long)_sc_ret >= (unsigned long)-4095 ){		\

The cast isn't needed any more, and (unsigned long)-4095 can better be
written as -4095UL.

Andreas.

-- 
Andreas Schwab, schwab@linux-m68k.org
GPG Key fingerprint = 58CA 54C7 6D53 942B 1756  01D3 44D5 214B 8276 4ED5
"And now for something completely different."



More information about the Libc-alpha mailing list