[PATCH v6] Also use l_tls_dtor_count to decide on object unload (BZ #18657)

Carlos O'Donell carlos@redhat.com
Thu Jul 23 20:01:00 GMT 2015


On 07/23/2015 01:49 AM, Siddhesh Poyarekar wrote:
> On Tue, Jul 21, 2015 at 10:29:27PM +0200, Torvald Riegel wrote:
>> Overall, with perhaps the exception of the reasoning about the relaxed
>> MO on the increment, and based on the conversation that I had with
>> Siddhesh, I think the synchronization in this patch is sound.  Thus, I
>> think that we can also do more word-smithing on how we explain it after
>> the release (so that this doesn't hold up the release then).
> 
> Thanks, I've pushed this now, with more changes to the documentation
> as per your suggestion.  Revised version is below.

This version fixes almost all of my suggestions from v6 (though this is now v7).

However, it remains that we use "load lock" and "load_lock" to talk about
"dl_load_lock".

I would prefer that all references be made to the real name of the lock
e.g. "dl_load_lock", in the even that some day we split the lock in two
that we don't have to go through and clarify which of the two load locks
we're talking about.

Cheers,
Carlos.



More information about the Libc-alpha mailing list