[COMMITTED] Use ALIGN_UP, ALIGN_DOWN, PTR_ALIGN_UP, pagesize, and powerof2 in more places.

Carlos O'Donell carlos@redhat.com
Thu Feb 19 02:54:00 GMT 2015


On 02/18/2015 09:39 PM, Mike Frysinger wrote:
> On 17 Feb 2015 19:24, Carlos O'Donell wrote:
>> Following up on this patch which had an ACK from Siddhesh:
>> https://sourceware.org/ml/libc-alpha/2014-12/msg00968.html
>>
>> I additionally audited elf/dl-reloc.c and changed it to use
>> ALIGN_UP, ALIGN_DOWN and PTR_ALIGN_UP as required. Makes the
>> code much easier to read at a glance.
> 
> nicely done ! :)

Thanks!

c.



More information about the Libc-alpha mailing list