[1/3] elf/dl-lookup.c: Move STB_GNU_UNIQUE handling to a function
Ondřej Bílka
neleai@seznam.cz
Fri May 16 21:03:00 GMT 2014
On Fri, Apr 11, 2014 at 04:29:46PM +0100, Will Newton wrote:
> Move handling of STB_GNU_UNIQUE symbols to a separate function
> from do_lookup_x in order to make the code more readable.
>
> The new function gets inlined with gcc 4.8 on ARM and the
> do_lookup_x code becomes a few bytes smaller.
>
> ChangeLog:
>
> 2014-04-02 Will Newton <will.newton@linaro.org>
>
> * elf/dl-lookup.c (do_lookup_unique): New function.
> (do_lookup_x): Move STB_GNU_UNIQUE handling code
> to a separate function.
>
Looks ok for me.
More information about the Libc-alpha
mailing list