[PATCH] S/390: Fix namespace violation
Carlos O'Donell
carlos@redhat.com
Fri Mar 14 21:44:00 GMT 2014
On 03/14/2014 01:02 PM, Roland McGrath wrote:
> If you're going to touch it at all , you should make it follow the new
> convention and be __glibc_reserved* instead.
Agreed.
See:
https://sourceware.org/glibc/wiki/Consensus
~~~
Anyone can commit a change to any header to rename __block to
__glibc_block or __unused to __glibc_reserved. Multiple versions
of the same symbol can be created by appending a number e.g.
__glibc_reserved1. Consenus was reached that glibc would use
the internal prefix __glibc to avoid name collisions with
other tools that comprise the implementation from a standard
perspective.
See https://sourceware.org/ml/libc-alpha/2012-02/msg00047.html.
Note that __unused is used by source from BSD that defines it as
the unused attribute for the compiler, while __block is used by
Clang's -fblocks extension.
~~~
Cheers,
Carlos.
More information about the Libc-alpha
mailing list