If that's actually the case, then there is no point whatsoever in having both macros in the first place. Instead of your last patch, just make everything test HP_TIMING_AVAIL and do away with the "small" distinction everywhere.